Funding Form Submit Errors

Incident Report for upstart

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:06 UTC

Update

Our product is currently experiencing unexpected downtime. We are actively investigating and working to mitigate this issue.
Posted Oct 20, 2025 - 16:00 UTC

Identified

Applicants are seeing increased errors when submitting the funding form due to an AWS outage in the US-EAST-1 region.
Posted Oct 20, 2025 - 15:25 UTC
This incident affected: upstart.com.