Upstart Issue

Incident Report for upstart

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 19:19 PDT

Monitoring

We are currently monitoring the fix that was put into place.
Posted Jul 10, 2026 - 18:32 PDT

Identified

Our product experienced unexpected degradation beginning at 4:24 PM PT. Teams are working to fix the issue.
Posted Jul 10, 2026 - 17:56 PDT
This incident affected: upstart.com.