Rate Check Errors

Incident Report for upstart

Resolved

We are fully recovered as of 10:38 AM PT and applicant experience has been restored.
Posted Jun 12, 2026 - 11:03 PDT

Investigating

Applicants are experiencing an elevated level of errors while checking their rate. We are actively investigating and working to mitigate this issue.
Posted Jun 12, 2026 - 10:32 PDT
This incident affected: upstart.com.